Issue thread (GDO blaq): Chamberlain RJO20 / LiftMaster 8500 / square yellow button

Hi - First post so be gentle :slight_smile:

I just received my GDO blaQ units and I am working to get them operational.

I am 99% sure that I installed them correctly but I am having issues. The doors are randomly opening/closing (at least it seems random) and the wall remotes are also randomly beeping and flashing. I am sure that the neighbours are wondering what I am up to :slight_smile:

A few Notes:

  1. I left the existing MyQ internet connection to the outside world enabled. I assume that is correct but can’t find anything in the setup instructions indicating one way or the other. I tried both with and without the MyQ internet connection enabled and it didn’t seem to make any difference
  2. My opener says that its security+2.0 but my settings are showing security+1.0. I have tried switching to security+2.0 but it doesn’t seem to save as it still says security+1.0 when I wait a few minutes and refresh. Not sure if this matters?

Thanks in Advance
SManCan

1 Like

This is the temporary install.

These are my wall remotes

1 Like

Here is a chunk of logs. This is after plugging in one of the units. It seems like allot of sync errors.
image

Then about 15 minutes after startup something reboots and then messages change. Wall remotes and other remotes were not touched during the 20 minutes.

@SManCan try changing the Security+ Protocol option to Security+ 1.0 (via the device’s web page). Then reboot it. I think forcing the Security+ 1.0 protocol on this opener may fix it. Your device has a yellow square learn button, which is not the same as the Security+ 2.0 openers with a round yellow learn button. It may work with the 1.0 protocol but for whatever reason cannot be auto-detected.

@Mike_S Please check the date code on the back of your 888LM wall button. We have heard from several customers that these wall buttons made before 2015 have some kind of issue/defect where they lose power or occasionally go offline when more than one thing is connected to the circuit. The fix is to replace the 888LM with a newer one of the same model. Easy to do, but it’ll cost you $50~$60 new (cheaper used on eBay, etc). What is the date code on your button?

@nate - Thanks for your reply.

A note/clarification from my inital post is that when then device initially booted up it displayed security+1.0 for the security protocol.

Here are the steps I went through just now.

  1. Set the device to security+2.0 and rebooted.

After reboot I am still getting random Open/Close, Lock/Unlock, etc. in the logs. The same behaviour as my initial posts.

  1. I then set the device to security+1.0 and rebooted as you instructed.

After reboot the door opened by itself again, so it seems that the issue remains. The logs do not seem to align with the current state of the door. For example, this displayed in the logs but the door is still wide open. No remotes were touched during this time.

For the garage door opener that I am using for this test, the MyQ app is not functioning correctly either, while the GDO blaQ is connected. The other garage door opener that I have excluded from this test (the GDO blaQ is currently connected but unplugged) works fine in the MyQ app.

This is the current web page displayed after rebooting to security +1.0

The logs have now flipped back to displaying the sync errors from my initial post.

I’m having issues with my unit too, same model. My wall button was made in 2016. I upgraded to 1.0.3 today and enabled VERBOSE logging. It doesn’t look like I can upload log files here though, so I’ll email those directly. I currently set to Security+ 1.0. I tested today removing the wall button completely to remove it from the equation.

We have a firmware update coming out tomorrow that I expect to fix this issue (or at least make it a lot better). Stay tuned.

A firmware update is now ready that we expect should fix this issue!

The update GDO blaQ project version number is 1.1.0 and was released in release 2024.5.4. There are also some changes to gdolib included in this.

There are three ways to update:

  1. Update over-the-air via the Konnected App. Go to Settings > Save & continue > Build now. Then wait a few minutes for your firmware to complete and tap Update Now to update wirelessly.

  2. Physically re-flash the device with a USB cable at install.konnected.io

  3. Users of ESPHome dashboard can update automatically via ESPHome dashboard.

After installing the update, the GDO blaQ should reboot and attempt to sync with the garage opener. If you have problems still, try changing the Security+ protocol selector to auto (via the device’s built-in web page).

Please let us know if this fixes the problem!

Unfortunately, the results were the same. Wall buttons would no longer work. I tried wiring to the openers and at the wall switches. I did not try pass-through.

On the lift master, connecting to the blaq’s corresponding connections for near the wall, I was able to open/close via SmartThings.
That was not the case with the craftsman.

The only thing that was consistent was the ability to open and close both doors via the device’s built in website.

Setting Security + to auto always reverted to 1 for the LiftMaster and 2 for the Craftsman.

1 Like

A quick update as I have been watching the other threads and decided to give things a try today. I plugged in the two GDO blaq devices and upgraded firmware to version 1.1.1.

After reboot everything was stable a working perfectly for approx. 6 hours, so definitely better than how things were working originally. However, after the 6 hours one of the two devices started acting up, wall panel flashing and beeping, etc. I then encountered some random behaviour as I did initially.

Here is a snippet at one point when it was throwing errors.

Very curious that only one of the devices started acting up, I am assuming that the other would as well at some point. In the end I unplugged both GDO blaq devices and things are once again back to normal.

I have tried setting Security+ protocol to Auto. However, after reboot the devise always reverts back to security+1.0.

Not sure if there is anything else that I should be trying but its now close to 3 weeks that this has been ongoing.

SManCan

@Ryan_P do you have any idea what would cause those “parity errors” in @SManCan’s screenshot above?