Issue thread (GDO blaQ): Purple button garage opener with 888LM/889LM wall button

We are currently working on addressing an issue with the GDO blaQ and Security+1.0 openers using the 888LM or 889LM wall button. At present, there seems to be a compatibility issue with the GDO blaQ and the 888LM/889LM wall buttons. We are confident that this can be fixed with a firmware update, and are presently working on a solution.

In the meantime, we recommend that you either:

  1. disconnect the GDO blaQ, or
  2. disconnect the 888LM/889LM wall button

Please use this thread to discuss related to this issue.

I have a similar set up and I am having the same issue/symptoms (i.e. random opening and closing). When I disconnect the MyQ wall remote, LiftMaster 888LM, the issues stop and everything works perfectly (including HomeKit integration).

I would like to get it working with the MyQ if I can though as none of my existing LiftMaster remotes work now.

1 Like

I am having this exact same issue. I had to unplug the Konnected because it keeps opening and closing the door (without sounds and lights, which is a huge safety issue).

I have a 2018 888LM.

I’d really like to identify a fix for this.

Is anyone working on this?

1 Like

Just checked and it is set correctly: Security +1.0

It has a purple square button
Date of opener: 11/07

I reconnected the old wall button and the same problem persisted. Random partial opening and closing. flashing lights on the wall button.

My hubitat / homekit integration starts working eratically.

When I disconnect the wall button the hubitat / homekit works perfectly again, but of course I lose my ability to control the garage door with the wall buttons (and MyQ.

1 Like

@Mike_S thank you for that information. We are looking into it. I don’t think the issue is related to your wall button in this case. I think it’s something related to the Sec+ 1.0 protocol in combination with the smart wall button creating some conflict in our code. Likely can be fixed with a firmware update but at this point I cannot give a timeline.

I have a purple square button. How do I alter it with the web interface. When I looked at it before, it looked like it was just a table with no buttons to update. I can’t go there now because if I plug it in, the door will start going up and down.

Also, mine also had the flashing red learn button off and on (it did it for a bit but seemed to go dark and then beep and come back flashing) on the wall button.

There’s a drop-down select to choose between auto, security+1.0, and security+2.0.

Purple and red/orange button should be Security+1.0
Round yellow button is Security+2.0

It seems like the GDO blaQ is doing a good job of auto-detecting Security+2.0 openers but not the older protocol. Try setting this manually to help it out. Our firmware engineer @Ryan_P is also looking into this.

I’ve been doing a little research on the issue and found that LiftMaster has extended the warranty on the 888LM wall panel and will replace it with an 889LM via this form.

Good info on this forum thread.

I am working on sourcing this same combination of equipment so we can test against it.


Thanks for the research on this. I filled out the form and received a coupon code, but when I enter the code, it says coupon code applied, but does not reduce the price. Looks like this extension ended in September 2023.

I’m at work now. When I get home, I will try changing the security protocol and let you know what happens.


I ordered some capacitors to “fix” (albeit temporarily at least) my existing wall panels.

Hopefully, the Konnected devices will support thread (or homekit) by then and then I won’t need myQ anymore.

When I select 1.0, it seems to take I guess but it still says auto next to it and when I refresh the page it still says auto. How do I commit the change?

Edit: I rebooted it and it now says 1.0.
If I disconnect the wall panel, it seems to work fine.
When I connect the wall panel, it flashes (the panel) and the door opens and closes at random.

1 Like

We are working on some improvements to the protocol auto-detection and selection features. On reboot the device tries to detect the Security+ protocol, and what seems to be happening with older openers (purple button) that something in that detection routine is triggering the door control unexpectedly. Please bear with us while we fix that.

We are also investigating how to improve compatibility with purple button openers and the 888LM/889LM wall buttons.

Currently the GDO blaQ is working perfectly with Security+ 2.0 openers in US/CA (those with :yellow_circle:). We are working out the kinks with older Security+ 1.0 devices, which will be solved in short time via firmware updates.

In the meantime please unplug or disconnect the device if you are concerned about the safety or unexpected movement.

Hi Nate.

I know this has probably been a busy week for you. I’d like to say, I appreciate what you all are trying to do to make this work.

Just wanted to share a little more information. I have 2 openers and they are both purple. (Although not the same model, one is much older than the other.) They are both connected to 888LM panels.

I received new Super Capacitors yesterday and today, I replaced the caps in one of my 888LM wall panels. I also hooked up the second BLAQ to the other opener to see if it had a different experience.

I’m using Wagos to make it easier to add and remove the BLAQ. With both openers (one with a wall panel that has not been modified and one with a wall panel with replaced Super Capacitors), if the BLAQ is not connected, the panel flashes fast Yellow and Red lights for a bit and then beeps 3 times and goes solid yellow and then works as expected.

If the BLAQ is connected, it flashes fast yellow and red for a while and then flashes yellow and red slow for a while and then beeps three times and all the lights go out. Then after a few seconds, it starts over and flashes red and yellow fast again.

I have not yet updated the firmware. I couldn’t get that to work yesterday. I’m going to try that next to see if I can get it to work and if it changes anything.

While I had the panels removed, I did confirm that I can operate the opener by touching the wires together, so I guess worst case, I’ll ditch myQ and just replace the wall panels with normal buttons.

Looking forward to hear if there are other possible solutions. Happy to participate in any other trouble-shooting you would like me to try.


I updated both devices. The first one I updated went to The second one I updated went to I reconnected the one with and it still does the same thing. (Not that I expected any different, just sharing what information I have.)


1 Like

Thank you for the update, @toddtmw.
Yes it’s been quite a busy week and we have are tracking and working on a few issues, but overall the blaQ is very well received by this first group of customers.

We’ve researched the issue, and from what I understand so far, upgrading your 888LM to an 889LM will fix all of the issues. I haven’t been able to confirm this myself yet, which is the only reason I have gone ahead and told you to go buy one yet. I don’t want to be wrong and cause you to spend unnecessarily.

I’ve ordered a purple button opener, an 888LM and an 889LM to add to our test devices. They’re not here yet. End of next week maybe.

My understanding is that the 889LM not only fixes the capacitor issue, but also updates the wireline protocol to Security+ 2.0.

Tried installing two of my three blaQs today. I am having the same issues: 888LM, purple learn button, flashing lights and constant opening and closing of the garage doors.

1 Like

Have any of you noticed reduced range on your remotes with the Blaq installed? Without it I’m able to open my garage door from several houses away, easily 150+ feet. With the Blaq installed I have to be in my driveway for the remote to operate, under 50 feet.

I also switched out my 888 button on my purple learn button opener for a simpler security+ button and the random opens stopped but the LED on the new button flickers and the light button doesn’t work at all. I’d be okay with the dumber button but the reduced remote range is really annoying.

I upgraded my 888LM to the 889LM (working with a purple button opener). I have also updated the BLAQ firmware to the, So, far I am still having issues, but reading your post it looks like the 889LM’s support of Security+ 2.0 should have fixed the issue. I did note that on the BLAQ webpage that it was set to Security+ 2.0.

So, I will do some more testing. When I unplug the opener and teh BLAQ does it matter which order I plug them back in?

1 Like

We’ve been working on this all day and have a firmware update that looks like a promising fix for this issue. I’m planning on getting it out tomorrow.

does it make sense that I am still having the issue after switching in the 889LM?