Konnected Fire Alarms not integrated correctly

I have existing fire alarms (4 of them) connected in series via my old alarm system I replaced with 4 Konnected alarm boards. Everything in ESPHome and Alarmo are working except for my fire alarms. I flipped the Invert Flag in the YAML code through Developer Tools->States for the Alarms entity. When I try to set the Alarm to Away or Home, I get an error “Could not arm due to the following sensors” and it shows the Alarm entity. I have tried to figure this out on my own and have spent 2 weeks trying to figure it out. I’m pretty new to Home Assistant, but I honestly thought I had it finally figured out. So, at this point, I am surrendering and trying to find help. What am I doing wrong? Thanks, Stu.

I found this article on the Konnected.io site. I am going to try this and once I have received the devices and performed the installation, I will report back here.

I am just now retrofitting my old alarm with Konnected. In my case there is a Kidde sm120x relay connected to one of my smoke detectors that is wired up in a normally open configuration (I think). Those are the two wires that go back to the alarm panel. That relay can also be wired normally closed. I think I have the closed vs. open correct, but the main point is that you can switch the wiring of the relay if that is helpful.

I just found this: Connecting 110-120V Hardwired Smoke Alarms

Thank you. I have NAPCO alarms. I’ll see if there is an option.

The relay is something the old alarm company added on to one of my smoke detectors. From the relay they ran a wire to the alarm panel.

I just swapped the wires on my relay to normally closed and all is good.


Ok, this is so easy. Go to ESPHome in Home Assistant. Select the board you need to invert (I have 4 Konnected boards). My Fire Alarms are on the 4th Board on Zone 6. In the ESPHome, select the Konnected board’s “Edit” link.

Add the code to invert the zone to normally closed.


  • id: !extend zone6
    name: “Smoke Alarm”
    device_class: smoke
    inverted: true


Finally, Save and Install the changes. Go back to the ESPHome and click on Visit. The Konnected Zone you changed should now show OFF.

NOTE: If you set the device_class to smoke and are using an alarm Integration like Alarmo, that device class will enable the smoke alarm to go off ALWAYS. So, regardless of whether you have your alarm system turned on or not, an activated smoke alarm will ring the siren. This is what you want, right? :slight_smile: