Issue thread (GDO blaQ): Purple button garage opener with 888LM/889LM wall button

I tried the workaround, but no luck. To resolve the issue with my S2+ opener, I bought an 880LM from Amazon dated 1/24 and I no longer have the panel issue with that one.
SmartThings integration is flawless, door status is updated right away.

I also tried the work around on the LiftMaster 8500 and it didn’t work. Has anyone been able to find a panel that works with Security 1.0 protocol?

Hi Dave.

I received an 889LM yesterday but did not have time to try it. Both of my openers are S1+. I will report back once I find time to try it.

It seems likely, that if the firmware of the BLAQ could be updated to not take over the protocol, then the 888LM’s might work for S1+ even after a power failure.


1 Like

Hey Todd,

Ok great thanks!

I saw that, sounds promising. Good luck with testing.

EDIT: I just went out and looked at it again, and it is flashing red and yellow. Looks like it does NOT work any better than the 888.

the 889LM seems to work. It’s weird though. It seems to do the same thing the 888 does. It flashes red and yellow for 30 seconds, but then it beeps, all lights are off, and then the yellow light comes on.

Seems like if the problem is the BLAQ taking over the protocol after 2.5 seconds, that the 889 would have the same issue.

1 Like

Does anyone know what the difference is between the 889LMMC and 889LM, if anything?

Okay, here is something else that has happened after I installed my three blaQs. I have the Liftmaster Wireless Keyless Entry 377LM keypad. The one-button close feature no longer works. To close the door with the keypad, I now have to enter the PIN and press Enter.

Well, I thought things were more stable. Today one of my doors has opened randomly twice.

This is getting old.

@nate have you made any progress testing on your end?

We’re going to be releasing another firmware update that adds a bring-up delay that should help from clobbering the 888LM/889LM and other older panels. @Ryan_P is still working on that and it should be ready for testing pretty soon.

@MarkW that’s surprising to hear and a bit concerning. Can you look at the uptime after phantom opening occurred and tell me if the device rebooted corresponding to those times? This will help us know if it’s a boot/reboot issue or something else.

1 Like

Spoke too soon, it is back to not updating status again in ST. Closed, but still reporting closing. I noticed when I returned home yesterday and the door didn’t open when the return home routine ran.

Yes, I was working in my garage and cut power to the openers. The openings occurred after each power cut; but not right after.

@Ryan_P , any update on the new firmware?

Also, is there somewhere where new firmware is announced and the changes are documented?


It’s currently in process, I needed to make some larger changes and have focused on that before I could address this issue.


I ended up purchasing an 899LM MC which has resolved the panel erroring out while the blaQ is powered on.

The new panel apparently has to be re-linked to MyQ and homelink no longer functions. I haven’t tested any other remotes, but plan on it shortly.

The door now opens on it’s own which I didn’t realize since I wasn’t getting the MyQ notifications.

ST device history reports the door opening about every minute and the reports it as closed.

I ended re-installing the old panel (for now). When I went out the 899 was resetting over and over again.

@Dave_Jones We’re testing the updates internally and I’m working on making them available for everyone ASAP. to solve your problem with the 888/889LM @Ryan_P has implemented a new protocol option called “security+1.0 with smart panel”. When you enable this, the blaQ will not try to emulate the smart panel on startup and not clobber the comms of your 888/889LM.

Will let you know when the firmware is ready for you. Thanks for your patience.

1 Like

We’ve made it a bit easier to test the bleeding edge / experimental firmware releases so hoping you guys can try this out. There’s now a dev build available that has the latest pre-release changes. @toddtmw @Dave_Jones let me know if you’re able to try this out.

This release-candidate adds a protocol option to the drop-down called “Security+1.0 with smart panel” that you should select if you have the 888/889LM digital wall button with a Security+1.0 opener (purple learn button). It should fix the issue with the wall button getting clobbered at startup.

Two ways to update:

1. Update via USB cable at

Connect your computer to the GDO black using a data-capable micro-USB cable. Go to, select the GDO blaQ and ESPHome firmware. Now you have the option to choose the stable or dev build.

2. Update via ESPHome

If you’re using HA and have ESPHome add-on installed, you can edit your config to build from the dev branch. Open the ESPHome dashboard, click Edit on your GDO blaQ device, and modify the last part of branch identifier in the packages line to dev, instead of master like this:’


  konnected.garage-door-gdov2-q: github://konnected-io/konnected-esphome/garage-door-GDOv2-Q.yaml@master


  konnected.garage-door-gdov2-q: github://konnected-io/konnected-esphome/garage-door-GDOv2-Q.yaml@dev

I was able to install the DEV firmware, however it no longer connects to my network. I went as far as doing a factor reset and re-discover with the same results.

I flashed back to production firmware and was able to connect to wifi.

I updated one of two of mine to test. It seems to not be clobbering the wall control now but it’s not working consistently. For example I couldn’t get it to operate with Homeassistant and even tried the internal webpage directly and it seems like I have to constantly push that resync to get things to happen. That’s my limited experience with it so far.

@Dave_Jones If you physically re-flash the firmware via USB it will wipe out your stored WiFi credentials (and Konnected Cloud credentials if enabled). You can re-connect to wifi by connecting to the konnected-xxxxx fallback network then open Right now there’s no way to use the dev branch with Konnected cloud but I may try to add that in the app in the future.

@slopster Could you share some logs from start-up and after sending a few commands via HA or the web interface? You can stream logs over the network either via browser or command line, see: remote logging how-to