Home Assistant & WiFi Issues

After a bit of an ESPHome learning curve I installed my Konnected opener last week. It’s working as advertised but with two hiccups. One is an annoyance, and the other a possible showstopper.

The first issue is in Home Assistant. All of my garage automations call the service “Cover:Open” or “Cover:Close”, with the garage door entity selected as the target. The openers I’ve used before have always considered the state of the cover first. That is, if the cover is closed and a close command is issued, the door stays closed. The Konnected opener is ignoring the cover state. For example, I can consistently call the “Cover:Close” service with the door closed, and it will open. Amusingly enough it will give its warning beep before opening. I can then call the “Cover:Open” service with the door open, and it will close. At all times the cover state is correct. The state is closed when the garage door is closed, and open when it’s open. I’ve worked around this issue by adding a condition in my automations to verify the cover state first. However, ideally the cover state shouldn’t be ignored. A quick Google search of “esphome ignores garage cover state” seems to indicate this is an ESPHome issue? Hopefully this can be resolved.

The next issue is with WiFi connectivity. I have a 3-node eero system. The Konnected opener won’t stay connected to the nearest eero node. At the moment it’s cycling between the closest node and the furthest node. It will stay connected to the nearest and much stronger node for a few minutes to several hours, but then for no obvious reason it will switch to the furthest and weakest node. While connected to the furthest node the HA Logbook fills up with “became unavailable” errors. I’m hoping there is some way to get the opener to stay on the closest and strongest node.

Hi. I’m going to answer you about the eero issue. It is a known problem with eero that devices don’t stay connected to the closest access point, even if the signal is weaker from another. With erro, to my knowledge, there is no current way to force a connection to a specific AP, unlike with other vendors such as Asus Mesh. Some users have scripted HA to periodically toggle Wi-Fi or the device itself to an on/off status, so that on reconnection, it automatically attaches itself to the closest AP.

I’m going to fix the state-aware toggle open/close. This has been reported a few times already here and here. Interestingly, the Home Assistant UI automatically disables the close button if the door is already closed, and vice-versa, but apparently if you call the open or close service directly it doesn’t.

Anyway, I will definitely fix this to make it behave more consistently, regardless whether using the UI or calling the service.

Regarding the WiFi connectivity, my suggestion would be to modify the wifi configuration in your ESPHome firmware and give it a specific BSSID of the access point you want it to connect to. Like this:

    - ssid: MyNetwork
      password: mypass
      bssid: AB:CD:EF:01:23:45

The above should force it to only connect to the access point with the given BSSID.

Thank you! Setting a specific SSID completely resolved the connectivity issue. Initially it wasn’t working until I discovered that I had to reboot the garage door opener before the setting would take effect. Since then it’s been rock solid. I will say that eero is much better than it used to be at keeping devices on the closest access point, but more control would still be nice. I think eero’s argument for not adding this feature is that ideally the client decides which AP to use. Before setting the SSID the GDO did seem to stabilize on the closest AP after a few days, but it would still occasionally jump. The SSID setting gives me full control.

Thanks for committing to fixing the state aware issue. How will that and other updates come through? Will they appear in ESPHome automatically?

I really appreciate the great support! What I’ve heard about Konnected is obviously true. My GDO is now stable and working perfectly.

1 Like