Failed to Install Firmware to your Device

I tried to update the firmware of one of my devices. It has very strong Wifi in the garage, but when I try to update it from my phone on the same network, it says Failed to Install Firmware to your Device.

This was from the app on my iPhone.

the email said to use Chrome or Edge, so I opened the link in Chrome on my Mac and after a while, I got this error.

I restarted it (incidentally, when I went to the garage to restart it, the door was half-open. HA shows it happened around when I was trying to do the firmware updates. I have completely removed the lift master wall panel there is nothing connected to the dry contacts input, so this was all Konnected, which is quite concerning. The door should not open or close without express intent from the user.)

After the reboot, the firmware update failed again from Chrome with the same error.


Thank you.

I would try the app over-the-air update again. It should eventually work. We have an app update coming out this weekend (hopefully) that should improve the OTA update reliability.

We are also working on some improvements to the protocol auto-detection and selection features. On reboot the device tries to detect the Security+ protocol, and what seems to be happening with older openers (purple button) that something in that detection routine is triggering the door control unexpectedly. Please bear with us while we fix that.

We are also investigating how to improve compatibility with purple button openers and the 888LM/889LM wall buttons.

If you are concerned about unsafe operation, please disconnect the GDO blaQ in the meantime until a firmware update to address these issues is available. It shouldnt be long. Or contact us at to request to return the product for a refund.