Ethernet connection

I have a comcast modem/router with four ethernet output ports. When I connect the Alarm Pro into one of the modem ports I get a green light on the Alarm Pro port, but a orange light on the modem port and the device is not found on my network. In reading other information, it suggests that the orange light may indicate incompatible hardware speeds. Do I need to have a different switch to make the two compatable?

I upgraded the modem to their current model and this did not connect either.

Hi. Is this a new Alarm Panel Pro you have, or an older one? On the newer panels, there is a sticker on the static bag the panel comes in, and it advises you to upgrade the firmware first before plugging an Ethernet cable in. If it is a new panel, can you do that if you have not already? If it is an older panel, then there should be no issue. The Ethernet on the panel is 100BASE-TX 802.3u, which is pretty common. Even if your router has a 1GB port, it is backward compatible with 100MB, so it will work. Have you tried a different Ethernet cable? Here is some information on how to flash the firmware.

Thanks for the response. I ordered this from Amazon about two weeks ago, and did not notice the firmware update notice if it was there. When it did not connect with the ethernet cable, I proceeded with the Wi Fi steps and have got it working. Once I got the system working using Wi Fi, I have tried to go back and use the ethernet cable method to connect to the system. I did try different ethernet cables, and the other day swapped out my Comcast modem for their latest model. I also tried to manually assign the device using the IP Address, but that did not work either.

Here is my information:
Device ID: 17c049ef512e
Model: Alarm Panel Pro (ESP32)
IP Address:
Software/Firmware: app v13.3 / fw v1.01-53178c

I am not certain how to upgrade the firmware?

A generic question… So the connection to the device is only used for setting up the system (sensors and zones) – right? Once that is done, all other functions happen on the SmartThings app right? I am installing this system using my old Honeywell sensors which all work, but when we discontinued our land phone line, communication to an alarm system stopped. We are out of town a lot, so this made sense to monitor while we’re gone. Once I am familiar with it all, I will be checking out the Noonlight monitoring option.

Thanks for your help

Hi Mark,

Please go to
Make sure that you are using a USB data cable. Flash the firmware to the panel that way, and the Ethernet should work fine once it reboots. This will be done really quickly.

Yes, the alarm logic lives inside the Smart Home Platform, such as SmartThings.
Finally, Noonlight is a good affordable option.

Okay, I must have a power cable not a data cable as I am getting an error when I try to connect - “no compatible device found”

Is there a down side to connect with Wi Fi instead of ethernet?

I got a data cable from Best Buy, and after several attempts, did get my laptop to communicate with the board. I did the install which I assume is the latest firmware.

It still is unable to find my device when the Alarm Pro is using the ethernet cable. I am trying to connect on my Konnected phone app (IOS) (wi fi) but it does not connect. Am I missing something? Can I configure from my laptop?

Thanks for your help.

At this point, I think I am going to give up on the cable connect.

Mark, there should be no reason for it not to work. Can you connect the USB cable again, go to, connect the board, and then download the logs ( you will see the option). Please send them to and mention that you were talking to Rory on our community site. The team will transfer the ticket to me, and I can look into it then.

@Mark_Baker It sounds like you have the latest firmware on the device so it should be connecting by Ethernet. When you plug in the device by Ethernet, does the blue STATUS light stop blinking? If yes, that means it’s connected to your network.

If you still cannot find it in the Konnected app, it might be because the Comcast router is not allowing discovery across the WiFi <> wired network. In this case, you can manually add the device using the IP address (find from your router’s status page) in the Konnected app. To do this, tap the 3-dots menu on the My Devices screen and select Add by IP Address.

It also would be helpful if you sent us or posted the logs as @Rory mentioned above.

I have the USB plugged into the circuit board and the ethernet is plugged in.
The green light is on, the blue light is off.
The ethernet light is green and flashes but not a regular pattern.
There are no entries in the log file.

I logged into the Comcast router, and looking at the Gateway>Hardware>LAN Ethernet panel, I found this: (I am plugged into port 2)

Associate Ethernet (with a checkbox)
Port 2 to XFINITY HOME Network:
Note: Associating Ethernet Port 2 to XFINITY HOME network will remove the port from your home network.

According to a Google search…
The ‘Associate Ethernet Port 2 to XFINITY Home Network’ checkbox is used when you are attaching a bridge to your modem.

The Device Manager in the Control Panel names the Alarm Pro “CP2101N USB to UART Bridge Controller” so if I check that box, will it then recognize it allow connection wirelessly?

Based on this, it sounds like the board is connected to Ethernet.

Click the “Reset device” link after connecting to the Logs & console to reboot it and start the output.

I don’t think this is what you want.

You should just need to go to the Clients or Devices list in your Xfinity app or management console and find the IP address of the Konnected Alarm Panel Pro. It may show up there as Konnected or Espressif or possibly some other name.

Nate - you got it right!

Logging into the router, and in the devices section, it identified the Alarm Pro device:

Host Name: espressif
Connection: Ethernet
Configuration: DHCP (one selected)
Reserved IP

I switched that selection to Reserved IP, which gave me an IP address, which I used in the mobile app. My phone NOW CONNECTS!

Thank you for helping out!