Device Not Discovered

When I click on "Tap here to start discovery" it goes to the next page stating "Please wait while we discover your device".  It just keeps searching for as long as I will let it, I have let it several times for over 5 minutes.  I have verified in the devices section on the router that I see the Konnected Alarm, I am on the same network with the device while searching.  I have power cycled the Konnected Alarm. When the board powers up I get the green light, the blue light flashes a couple of times then goes out.

I am having the exact same issue here on my new install. Were you able to resolve this issue ?

My problem was that I didn’t understand that I needed a SmartThings Hub with Home Assistant running, I was thinking Google Home Assistant running. So I didn’t have the correct hardware. They sent the link for the required;

So short answer, no but only because I haven’t gotten the hub

I am having the same problem. I just deleted the SmartApp and device handlers. Will try again and see if it works.

Ok. I added everything again from GitHub and it found the board. Hope this helps someone else.

I don't know what went wrong the first time around.

Device discovery can be hindered by several things. Most of them are related to your router setup. Check out our troubleshooting article for more info.




I am having the same problem.  I have inserted screen shots to show how I have set everything up.  My device handlers do not have anything in the OAuth column but I don't know if this is a problem or how to change if required.  However, as you can see, my smartapps do show true in OAuth.  You can see from my logs screen that it is trying to discover devices but can't find any.

Hope someone can help.


Take a look at the troubleshooting article above. Most of the problems in discovery have to to do with router settings. It will guide you through looking at your router.


I have 5 boards that are able to be discovered on my network but I have a 6th board that will not discover for anything.  I am not sure why the others will connect and the last one will not.  I have tried changing the settings on my router but with no luck.  I have been at this for the past couple of weeks.  Please help.   Thanks.

If the other boards discovered but not the last one it is not a router issue. It is probably a wifi module issue. Can you verify it is on your network? I would probably flash the firmware/software on the board and reset it on the network. Then try discover again. If that doesn't work send us an email at And we can exchange the board if we need to.

I can’t get SmartThings to discover my new Konnected device. It just keeps spinning. The spinner kind of blinks on the screen for a second. I’ve read all the fixes - I made sure I’m on the same network. I changed my router setting. I reset everything. Still not finding any device. Not sure what else to do???

Take a look at the article on Device Discovery. It is usually one of these problems.

1. You don't have your hub physically plugged into the right spot. It needs to be on the same network as your Konnected boards. If it is absent or plugged into another device that's an issue.

2. You have wifi extenders or access points that are messing up communication. Turn them off. Reboot the Konnected boards. Make sure they connect and try discovery again.

3. Your router is blocking communication between your wireless and wired networks. You will need to look at the various settings to determine what might be interfering. 

Does it matter which Smart Things app I use, classic vs. new?

I don't know why you shut this... my reverberate likewise quit perceiving my "gadgets" introduced by fauxmo and was following this to check whether there would be a fix distributed. It was working fine up until a couple of days back... would it be advisable for me to open another issue?  if you have Telstra wifi device then you can How to setup Telstra Wi-Fi Connection 

Start the establishment procedure once more, yet make a point to interface your base station to your switch before you control on your base station. For more data about associating your base station, perceive How would I interface my Arlo or Arlo Pro base station to the Internet? Apple repair service gold coast

I had this same issue trying to move my stuff from smartthings to hubitat. I never could properly uninstall konnected from smartthings. I even tried to remove the entire connected app. I keeps giving me an unexpected error. I went as far as manually deleting all the devices and the app still won't delete. So, I took the smartthings offline while I tried to do the install in hubitat.


The first module with a single device zone and no output went on really fast. The next module was a 3 hour ordeal of flashing the latest firmware/software, attaching, removing, doing this that and another thing. I finally got it on and the devices defined. Then the next three modules...AAAAARRRGGGHH. For hours I tried everything. Sometimes the discovery process would see it and sometimes not. I finally had to do what 65coupei6 did; delete the app and drivers then reinstall everything. That worked. Every module was discovered and loaded smoothly like it originally happened when I put it in Smartthings. I suspect something got corrupted.


There were a couple of things I noticed that may help others:


1) Some of my previous attempts included renaming the module by replacing the default name: Konnected-F9F9F9 was renamed to Konnected A. I think the renaming may have caused some issues. No proof of it; just a guess. Maybe it was the space. I don't know. But I did notice that as I jumped between pages of the renamed module, sometimes I saw the new name and sometimes the old one. During the last install, I eliminated the renaming and am living with the default names. I may try renaming one later but I doubt it.


2) A couple of attempts resulted in the module being installed but no devices were created. I was filling in all the zones and output during the initial install. My output device was an existing virtual switch. I found all of the zone devices were created properly only when I left the output section empty during the initial assignment. I then went back and entered the output section as a separate operation.