No state changes seen in Home assistant

I set up Konnected today with the wiring from the pre-installed home security system in my house, which includes 2 motion sensors and multiple door sensors which are split into 10 zones.

I followed instructions as per the site.  I did not run into any apparent issues while installing - the wifi modules seemed to connect to my wifi just fine and show up as connected devices when I look at my router.

I configured in Home Assistant as per instructions as well.  The pertinent part of my config file is as below:



  access_token: (deleted)


    - id: bcddc282723e


        - zone: 1

          type: motion

          name: 'Front Room Motion'

        - zone: 2

          type: motion

          name: 'Living Room Motion'

        - zone: 3

          type: door

          name: 'Front Door Sensor'

        - zone: 4

          type: window

          name: 'Office'

        - zone: 5

          type: door

          name: 'Mud Room Door'

        - zone: 6

          type: door

          name: 'Living Office LF'


        - zone: out

          name: 'Siren'

    - id: bcddc28270fe


        - zone: 1

          type: door

          name: 'Basement'

        - zone: 2

          type: door

          name: 'Garage'

        - zone: 3

          type: door

          name: 'Dining'

        - zone: 4

          type: door

          name: 'Living RS'

        - zone: 5

          type: door

          name: 'zone 2-5'

        - zone: 6

          type: door

          name: 'zone 2-6'

When I start home assistant, everything shows up appropriately (i.e, the binary sensors are present).  Everything is marked as closed however, and does not change when I open or close the doors, or walk in front of the motion sensors.

I saw recommendations to access the konnected device directly via the IP assigned by my router on port 23239, and tried this, but I cannot connect.  I have tried rebooting everything, from the konnected boards themselves to home assistant to my router, and nothing has helped.  

Has anyone had a similar problem, or have any ideas how I can fix it?

I'm seeing the same thing on a fresh installation.  Everything shows up, just never see a state change.  Additionally, getting this in the log:


2019-04-17 07:03:26 ERROR (MainThread) [homeassistant.core] Error doing job: Future exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/konnected/", line 131, in device_discovered
    setup_device(host, port)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/konnected/", line 121, in setup_device
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/konnected/", line 284, in setup
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/konnected/", line 388, in sync_device_config
    if self.desired_settings_payload() != self.current_settings_payload():
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/konnected/", line 368, in current_settings_payload
    settings = self.status['settings']
KeyError: 'settings'
2019-04-17 07:57:48 ERROR (MainThread) [homeassistant.components.updater] Got unexpected response: None


i am having same issue. any resolution?

figured out my problem. i was having trouble with discovery. HA was in a different VLAN than all my IoT items including the sensors. I had to enable mDNS in order to get them to communicate.

I've been using Konnected with Home Assistant successfully for a few months but starting yesterday, Home Assistant doesn't recognize any state changes in my sensors.  I have the same error log as Stephen.  Any fix to this?

I just found the same thing.  I have the following:

  • Konnected IO with 3 doors on it
  • z-wave setup for alarm
  • Raspberry Pi running HASSIO 0.91.4
  • Apple TV as the primary interface for the household to manipulate alarm setting
  • HADdashboard on android tablet near a door to one day use as an alarm panel - still a work in progress

I noticed this morning that the HADdashboard said the front door was open.  I checked, and it was closed.  Tried opening and closing all doors and nothing changed.  Rebooted the HASSIO system and everything went to closed, but again couldn't get the sensors to change.

I updated HASSIO to the 0.93.1 release, and now everything works again as previous.

Unfortunately, updating the HASSIO to the latest version, now 93.2 has not resolved my issue.  I'm going to try a clean install and see if that makes any difference.

A clean install of HASSIO did not resolve my issue.  However, I got everything working again after flashing the Konnected boards with the latest firmware, 2.2.7.

I recently purchased a few Konnected boards and a Rasberry Pi, and installed Home Assistant. The konnected boards show up in my Luxul router page - so I assume they are configured properly. I followed the recommended instructions for installing hassio on the Rasberry Pi, and utilized the Home Assistant Add-on Configurator to edit the configuration.yaml file.

From the Home Assistant APP, I’m not seeing any state changes. Not sure where to start. Any advice would be appreciated.

I am seeing the same problem.   I cannot see updates in Home Assistant from Konnected boards.   My devices came  pre-loaded with 2.2.7 

My system is also exhibiting the same behavior. The Konnected board is 2.2.7.

My rpi3b+ was downloaded this week is hassbian on buster.

I've followed the wireshark debugging guide and am able to capture at both wifi and at a hub in front of the rpi. I see SSDP broadcast notifiying that the Konnected board is up but I do no see any SSDP "ST" broadcasts from hassbian. The hassbian system sees the Google Home devices and Cast devices broadcasting. I think something is broken in hassbian....

I had success in the HA discovering my Konnected device after adding this to the HA configuration.yaml:



 - konnected

I tried the discovery:, enable, etc., still no dice.  Raspberry Pi and this are all new to me, so not sure if I have something configured incorrectly or not.  How do you really know Konnected is "connected" to Hassio?  Sure, I see the states, but is that based on what I have in the configuration.yaml file or?  I do see the Konnected wifi modules on my AP and routers.

I am having the same issue anyone fix this 

do you need the API host in your config ... 

I tried both - with API host in config and without.

BTW, I connected to the Konnected board just to see the device status and I have no Binary Sensors listed and nothing in the API location.  Not sure if that is correct or not.  

Also, not sure if others have had it, but the Konnected boards seem to drop wifi connectivity after a while.  I reset by pulling the power and it connects.  Not sure if related.

don't know what to do at this point may return unit  

Well I emailed Help on this and included this thread.  Perhaps someone will pick it up.  Really would like this to work.

I posted this thread a while back but then figured out how to make it work and had not paid attention.  What solved my problem was to update the firmware on the Konnected boards through the process listed on the website.  I had assumed it was the latest version, but updating did fix my problem and it has worked flawlessly since, so give it a try if you haven't.

I am having the same issue... I had Konnected working back a month ago (3 boards, 16 zones) with my existing sensors and hassio on a PI. Then I lost my SD hard in my PI due to heat. I got my PI running again with a new card and heat issue fixed.

Since I reinstalled hassio none of my sensors are detecting changes. I see them all listed in the dashboard but no state changes.

I would really like to understand how to debug this issue. How do I know if HA is talking to Konnected?