Configuring GDO BlaQ for HomeSeer

This relates to a post over on AlarmPanelPro as well.
Related Thread
I just received two BlaQs and am trying to configure them for HomeSeer.
In exchanges with Nate, he configured the new Firmware so that if will always include REST apl in the ESPhome Firmware. In consulting with Dr. Google I see that mDNS api is always included in REST but it may not be turned on.
The AKKonnected Plugin for HomeSeer requires mDNS to find the device.
Out of the box, the BlaQ does not appear to be advertising mDNS. I used the zeroconfServiceBrowser on my PC to look for mDNS clients and it’s not found.

SO, I tried using the app to generate a new Firmware build with just Native Web enabled.
The over the air update failed (as it did on the Alarm Panel Pro.)

I then tried to update the firmware using USB. I used the web page. It successfully flashed the BlaQ but I’m confused about what FW I flashed. In the past when I used the app to create a FW build, then went to, it asked me if I wanted to flash the FW I just built. This time it did not. So did it flash the FW with the settings I input? Or did it just flash a factory FW? And how do I tell?

In any event - after flashing with just Local Web Page / API enabled, the device still doesn’t show up in the zeroconfServiceBrowser OR the AKKonnected plugin.
And, as I said, the over the air update isn’t working.

Out-of-the-box all of the products (including the new GDO blaQ) on the latest firmware will have the Native API and Web API enabled and will advertise both the _konnected service and _esphomelib service. The _esphomelib advertisement will go away if Native API is disabled.

@BuddyRayAtl your two new blaQ are pre-loaded with the latest firmware, and once they’re connected to WiFi should be advertising on mDNS.

mDNS must be working otherwise the app wouldn’t find them!

The site hosts our “stock” firmware for each product. These are the generic/factory builds that are pre-loaded on the device when they ship, and are built from the open-source product firmware configurations in konnected-esphome. The project version of these stock firmware in the format MAJOR.MINOR.PATCH, for example 1.0.2 is the current stock firmware for the GDO blaQ.

When you customize a firmware build in the Konnected app, we basically applying some customizations to the stock firmware and building a unique firmware build specifically for your device. The customized project version we tack-on an extra digit which is an incremental counter that increments every time you make a new build. For example, if you were to customize the firmware for the blaQ built today, the project version should appear as with the last 1 indicating your 1st custom build. The customized firmware can be pushed over-the-air from your Konnected app, OR you can flash it physically at This is on a separate domain that requires login because these firmware builds are private and made specifically for you. Once the build is complete you will get an emailed link to flash the build by computer, or you can just go to and log in and navigate to your device.

As mentioned in the other thread, we’re workin on updates to the app to address some of the OTA update challenges. Sorry it’s not working for you right now.

I just installed in my garage the GDO blaQ and implemented the GDO blaQ in HomeSeer with the AK Konnected Alarm plugin. It may be too soon to state this, but the hardware and software so far are brilliant! It is doing just what I hoped with my garage door opener. Thank you! I do have some initial questions, though, and it may be for the plugin author to answer.
What are the functions of the “Learn” and “Lock” devices? Thanks. Elliott

OK, my bad.
I just restored both BlaQs to factory firmware, put them on WiFI and they are advertising mDNS.
Then I generated new Firmware in the App with only the Native Web enabled and that worked as well.
And guess what - the over the air update worked as well. The only snag was that it updated the first of two BlaQs just fine. Then I generated FW for the other one, and that OTA update failed. I tried several times, it failed every time. I had to completely close the app, reopen it, then the OTA worked for the second device.

But here’s the interesting thing. With new FW installed (and the Project versions do look updated to the mDNS is still advertising BOTH _konnected._tcp. AND _esphomelib._tcp.
_esphomelibe did not seem to go away when I turned off the Native API.
However, the device doesn’t appear to be rebooting constantly, so as far as Homeseer is concerned - mission accomplished.

Now I need to get out the ladder and actually install the both of them on the GDO and test all the functions. I’ll report back in a day or two.

Here’s what happened on my earlier test. I didn’t realize that flashing new factory firmware makes the device “forget” it’s WiFi settings. That’s probably why you added a link to the site to set it from there :-).
For some reason it doesn’t look like that link from to set WiFi login on the device is working for me. No errors, just hangs on the screen. So the devices weren’t on mDNS because they weren’t on WiFi and I didn’t think to check that.

Thanks for the very clear explanation and instructions above. I guess you know you need a section on configuring for HomeSeer in at least the online documentation if not an insert in the printed doc so dummies like me don’t start making assumptions. :slight_smile:
Also, just FYI, I used the wrong web page to try USB flashing because I never opened my e-mail, so I never saw the very clear instructions there. When the App failed to do an over the air update, I just opened the browser and looked for the web page to flash, and Google pointed me to the wrong one. Perhaps a fine print note under the Install button on the app “If over the air fails, look for instructions in the e-mail we sent.” would minimize support calls from over confident people like me.

I may have spoken too soon. The unit is rebooting every 15 minutes. But perhaps that’s because it’s not actually hooked to a GDO and is looking for it. I’ll get them hooked up tomorrow.
In the mean time, here’s the log file from one of the devices. Perhaps it can explain why it’s still advertising esphomelib.
Wait - how do I send you a log file, it won’t let me upload a txt file?

@BuddyRayAtl I checked into your device config settings. The config settings/customizations are blank. Not sure why … this sounds like it may be a bug in the app. It could be related to why you’re also having problems with OTA.

So, as a result, the custom config that you built is just a copy of the stock firmware. So that’s why the Native API is still enabled even though you thought you were disabling it.

I don’t know why you are having such problems with the app. It seems to be working well for most people. Can you double-check that you’re on the latest Konnected app version (1.4.0)?

@Connor_Martin just opened a PR for some app updates that I will review today and hopefully get an update out that smooths out these issues.