Firmware customization via Konnected app for Homeseer

Nate,
I finally got around to building a FW using the app and uploaded it to Alarm Panel Pro.
At the moment, The Konnected App finds the device and can display the web interface, but Alex’s plugin no longer finds the device - something I’ll ask him about on the Homeseer forum.
BUT - I wondered about WiFi vs. Ethernet. The old FW update process asked which you wanted? This process never asks, either when configuring the FW Options or when uploading. So, does the FW now automatically detect internet connection? Does it prioritize hardwired?

Here is how I set the Settings - should this be correct for HomeSeer?
Name: Alarm Panel
Zone Settings: I enabled all 12 zones and set them each to a custom name and set the type.
Enable Konnected Cloud: Disabled
Local Native API: Disabled
Local Web Page / API: ENABLED

The App and the build and upload process is very elegant by the way. Now to just get it to work with Homeseer :slight_smile:

Nate,

OK, I’ve been experimenting and “Houston, we have a problem.”
If the native API is not enabled, the Alarm Panel Pro DOES NOT show up on mDNS. And so Alex’s plugin won’t find and configure it. It can be manually installed using the IP address but this is a) not user friendly and b) has some side effects, like Homeseer doesn’t pick up the device name, doesn’t configure icon’s correctly, etc.

We need an option that:

  1. shows up on mDNS scans
  2. does not reboot every 5 minutes if it doesn’t find Home Assistant.

Or - is there a way for Alex to fake it and make Homeseer look like a HomeAssistant client is connected?

Nate,
Any thoughts on this since you split it into it’s own thread?

Yes, I will address this. I see what the problem is, and I think I have a good solution. I have a few other things to wrap up ahead of this but will circle back on it soon.

@BuddyRayAtl @alexbk66 I addressed this in a recent firmware update. See release 2024.3.2 notes here.

Basically I’ve added a _konnected mDNS service advertisement that is always present, even if the ESPHome API is disabled. I didn’t realize that disabling the native API would also nuke the mDNS detail.

You can update firmware by rebuilding a new version in the Konnected app, or starting over from scratch by installing the base firmware via https://install.konnected.io

Nate,
That should be perfect.
However, I’m in Texas visiting family for Easter and will stay through the eclipse. Be home around 4/18. I’ll test then. I just didn’t want you to think I was ghosting you :wink:.
Just living my best retired life.

No rush on my side. Enjoy the break.
I think @alexbk66 will have to update the Homeseer driver to scan for the new service name before it’ll work in Homeseer. I’ve tested the mDNS broadcast of course and it’s working fine.