Changing binary_sensor to switch in home assistant

I’m trying to get a second piezo set up with either my 12 zone pro or 6 zone panel with Home Assistant. “Out1” on the pro panel automatically gets set up as a buzzer in HA but I’d like to set up a second one with a different tone. I have extra zones so changing one to be an output seems to be the way forward. But… I can’t find a way to change a konnected zone from binary_sensor to switch in the HA ui.

It looks like the zones are set up automatically in HA when the esphome device (the konnected panel) is added and they can’t be re-configured in HA without some work.

This seems to lead to a solution but it looks like I need to change the config of ESPHome, reflash the panel firmware, and then re-add it to HA? Can I use the ESPHome add-on in HA to configure ESPHome and update it?

I didn’t get a response here so gambled and I went the route of using the ESPHome add-on in home assistant to configure the konnected alarm panel pro board. It did a lot of updating of firmware on the konnected board… and it looked like it never finished updating. Now the board randomly becomes unavailable for 3-4 minutes and then shows back up as a “new” device in homeassistant with same id. Ip, etc.
So basically it’s not usable as an alarm anymore because it’s not at all stable. I’m assuming I need to reflash the board with the konnected version of ESPHome firmware and set everything back up.

The reflash with konnected firmware didn’t solve the instability issue so I’ll take it to konnected support.

fwiw I’m pretty sure the problem I had with updating from the ESPHome add-on in homeassistant was from the “pin reuse” thing described here. So my hunch is once you got around that you would be able to ecit ESPHome configs on the konnected board from the ESPHome add-on…

I can confirm that you can edit ESPHome configs in the ESPHome add-on. I have been doing so without any issues until the error you are describing occurred for me.

Update … I found the source of instability in my system… I use a synology router and had two settings on the router that were causing problems.

  • “smart connect” which automatically connects a client to the best radio (5g, 2.4g) was enabled. It shouldn’t have mattered since the konnected board is 2.4g only, but it was causing random disconnect/reconnects. I have a mesh network so it might have been tossing the connection from one access point to the other.
  • auto reboot at set time was enabled causing the whole HA/konnected system to generate a bunch of logs each night.

Thanks to Adam from konnected tech support.
Thanks for confirming the bit about ESPHome add-on.