Board not detected - Invalid UUID structure (plugin v1.0.1)

Hi Mike, thanks for this release - It seems jam packed full of cool features and I can't wait to check it out!

Right now, I'm struggling to get my NodeMCU with Konnected firmware to be detected in HomeBridge.

HB Log:

[Konnected] 8f655392-a778-4fee-97b9-4825918a399e7 is an invalid UUID structure for the panel at

It worked in the previous release of this plugin.

I've reset, rebooted multiple times, etc. Eventually resorting to a full reinstall: Re-flashed board firmware (2 boards) and formatted the SD card on my Raspberry Pi and reinstalled a fresh vanilla Homebridge image from scratch, with no additional plug-ins.

Still no luck.... any suggestions please?

I am able to reproduce this on my end. It has to do with the V2 and NodeMCU boards and their SSDP USN UUID being an invalid UUID as compared to the RFC 4122 spec for UUIDs where it should follow the four hyphen "-" characters to obtain blocks of 8, 4, 4, 4 and 12 hex digits.

In this case the V2 boards have the last 12 hex digits totaling to 13 hex digits instead.

I am devising a plan to retain the meaningfulness of the numbers as they are loosely based on the MAC address too.

Look for an updated release in the next hour or so.

@Shaun, a new patched release is out. Please update your version and let me know if that fixed this specific issue.

That was super quick! Thanks @Mike, that did the trick!