Alarm panel pro fail after firmware update

 I have an alarm panel pro that wasn't updating its state in home assistant. After reading through the guides it seemed like it might be a firmware issue. So I decided to update the firmware. After a successful update to 3.0.1 the devices green power light and blue status light remain on permanently. I connected the device via usb and putty. The output is as follows...

flash read err, 1000
ets_main.c 371
ets Jun  8 2016 00:22:57

waiting for download

It appears to be waiting for a firmware download. After pressing the reboot button the same log output appears. I tried rolling back the firmware with the same results. Can anybody provide guidance on how to resolve this issue?

I get exactly the same now, after letting it update itself to the newest firmware. :-(

I spoke with support and found out that version of the firmware isn’t for the pro boards. Updated to the correct firmware for the pro fixed my issue. Here is a link to the method and correct firmware file is on the same page.

That just  worked for me too. :-)