Python error

Hello meanwhile waiting for the final PR approve I wanted to play a bit with my device and I have installed a brand new Hassbian installation (68.1) and upgraded with the konnected git source with the procedure describe on the website. My konnected device is connected to wifi ( I see it on my router) I have wired one zone and im trying to test it with home assistant. here is my configuration.yaml :

  auth_token: adsd78sj3wsa2g3
    - id: fdf2b1
        - zone: 1 
          type: door 
          name: 'porte arriere'

I see the door icon on the top of HA main panel, but I have an error in the log : 

Any idea, thank you ?

Log Details (ERROR)

Tue May 08 2018 19:15:58 GMT-0400 (Eastern Daylight Time)

Error handling request


Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 381, in start
    resp = await self._request_handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 322, in _handle
    resp = await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 88, in impl
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 68, in staticresource_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 27, in real_ip_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 68, in ban_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 28, in auth_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 104, in handle
    result = await result
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/", line 279, in put
    payload = await request.json()
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 537, in json
    return loads(body)
  File "/usr/lib/python3.6/json/", line 354, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.6/json/", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.6/json/", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Can you try updating to the newly released Konnected 2.2.0 firmware:

Hello Nate, Yes!! that what I did a few minutes after posting this problem, it solved everything. Thank you! :)

Great. Glad that worked. I had tried to make the Home Assistant component backward compatible with 2.1.4 but I guess I need to revisit that. Thanks for letting me know.