HA Configuration Fails Error Message

My Konnected Pro has been working well with Home Assistant.

However, I made changes to the configuration and I am now no longer able to reconfigure. On uninstalling / reloading the Integration, I continue to receive the following error message:

"User input malformed: extra keys not allowed @ data['8']".

My HA has just been updated to 2021.12.1.  Any thoughts or help?

I am having the same error.

Home Assistant OS 7.0



Raised a ticket and their engineers have identified a problem in the most recent HASS build (12/21).  They are planning on a fix by the next build (which I think is Feb). Seems a long wait, particularly as their have already been 2 breaking changes updates to HASS since; but they have suggested going back to earlier build (11/21).  Not sure why we need to wait so long. Seems this will shut out anybody who has just purchased or installed

Same error here. Just received the board and can't start using it. And now I need to wait for 2 months? There has to be a quicker fix.

Indeed roll back to earlier build as specified above.  However, I think for me that is highly unlikely (and difficult as all my other integration and automations have been updated to most recent Home Assistant build.

I think we need to put some pressure on Konnected

They were very responsive; I suggest raise a ticket on the menu above and see whether you have the same problem and whether they can get this accelerated.  I would point out to them that Home Assistant has interim updates for breaking integrations

I just installed Konnected today and am stuck at this error.  Bummer.  

raise a ticket and apply some pressure ..... 

Thanks for those that posted here, kept me from troubleshooting for too long.

I ended up backdating to 11.5, configured my Konnected Pro, then updated again, all is well

I submitted a ticket.  They said it'll be addressed in the Feb. patch.  Unfortunately, it looks like I won't be setting up Konnected over the holidays like I had planned.

I noticed last night that the configuration is now working.  It was after the latest HA core update.  Seems to be back up and running! Happy Christmas!