Konnected sensors and switches multiplying

I need to add that this is only when I have the konnected board assigned to a fixed ip.  If I have DHCP it connects to wifi but then I get the duplicate sensors.

@Dan Vitacco, i had this same issue of it getting new IP's while using Meraki, fixed IP 'contained' the issue. 

Thanks @Andrew Riley, For some reason when I switch to fixed IP it will not connect to the Meraki.  Did you change any other settings on meraki or on the konnected boards?  

@Dan Vitacco - I'm using "Konnected Interface" and still don't have it working just yet so behaviour 'could' be different; can't discover it in HASS or Python module. 

In Meraki i have it as a 'reserved address' from DHCP, not static on Konnected interface.

I will try that.  I tried to just assign a fixed ip through the meraki interface and it would not connect.   I will try to assign a fixed from a reserved ip and see if that works.    I ended up just grabbing an old router and using that just for my konnected network that hangs off my meraki environment.  Ill try it this weekend.  

Hi @Dan - I fired up console access on my Konnected Interface and see that its actually not connecting to my Meraki Wifi. 

When I look at the meraki event log i can see that Konnected interface is being 'deauthenticated' , if i move this over to another 'less complicated' wifi solution then it boots according to https://help.konnected.io/support/solutions/articles/32000023786-device-debugging-with-screen

So this looks to be something specific to a Meraki environment. For the Konnected Panel at least.

I'll keep digging.


yep that is what I was seeing as well.  Really weird, right? Like I said I just used an old dd-wrt router that i had off my meraki environment to connect the konnected devices to.  Have them on their own network.

Let me know what you find.  Honestly that consumed a good 2 weeks of my life and I just gave up.

Hi Dan, I think i've gone around in circles but have somewhat of an answer. 

If Meraki dishes out IP's then i get the 'circular' IP address issue and what looks like a constant reboot. 
If I configure Meraki DHCP to 'fix' the IP then I don't get any connectivity.

I found this post


I'll open a Meraki TAC case and get some more info.

Hi Dan, some success. 

NodeMCU build 20180917 powered by Lua 5.1.4 on SDK 2.2.1(6ab97e9)

Heap: 39504 Initializing Konnected (XXXXXXXXXX)

Heap: 34208 Version: 2.2.4

Heap: 32552 Connecting to Wifi..

Heap: 32168 WiFi not configured

Heap: 32136 Entering Wifi setup mode

Heap: 24152 WiFi Setup started

> Heap: 31104 Wifi connected with IP: 10.X.X.86 10.X.X.254

Heap: 36048 UPnP: Listening for UPnP discovery

Heap: 35688 HTTP: Starting server at http://10.X.X.86:10558

Heap: 35512 Loaded: server

Heap: 27024 Endpoint: nil

Heap: 26992 Loaded: application

Using fixed IP set in Meraki, no reboots

I can load the http page from Konnected and get the webserver to respond. 

Following the suggestion from here: https://community.meraki.com/t5/Wireless-LAN/ESP8266-and-frequent-reconnects-fail-with-latest-AP-firmware-MR/td-p/12707 

to set SSID encryption to WPA2 only 

node.restore() , configure to my wifi and bingo! 

Will attempt to configure in HASS shortly. 

now is not working :( back to the drawing board.

What i found was that as soon as the konnected device rebooted is when it started failing again.  This includes any updates to the pins on the board would cause it or a reboot of Home assistant as well.

Frustrating I know I see no reason why it should not work. Like I said I went to the dd-wrt router I have and had not had an issue since.  

I believe I'm running into this issue now as well.  I've been running this on Cisco 3800's for a while now without issue.  I recently brought up a pi-hole DNS server and switched over to that DHCP server and killed off the scope on the other router.  Afterward, the primary Konnected node is just flashing but isn't coming up properly.  The secondary board is working just fine.

The kicker here is that the primary comes up, it associates and authenticates to the wireless, and pulls an IP address.  However, it's not reachable.  I can see the MAC address and IP address in the network, but I can't ping it.  Since it's connecting to the wireless and getting an IP address, it's not broadcasting its own SSID.  

Since it's not reachable at all, I suspected that removing it from SmartThings would have no affect, but I tried anyway.  Strangely, SmartThings throws an error each time I try to remove the primary and won't actually remove it.  Not really sure what's going on there.  

I can try bringing the radios on the AT&T router up and broadcast the same SSID.  This might help to determine if there's an incompatibility with Cisco/Meraki APs.


I have the same issue connecting the konnected board to my Meraki network. Any luck of solving the issue?


 I am also having the same issue, but only on the Switches: Siren, Strobe, and Buzzer.  I am getting a +1 (e.g., switch.siren_5) on the switch name after each reboot.  Seems that the recent Home Assistant update - 0.91.1 might have created the break.  This was not a problem prior.  I have Reserved IP's on both Konnected boards.

I am having a similar problem with one panel. I have five Konnected panels installed, two development boards and three V2 with NodeMCU. I recently switched to cloud integration. I deleted all my zones and re added the to the boards. I am still in possession of an extra NodeMCU which was used prior to cloud integration. It is not connected to Wifi no it is powered. My ST app is showing the zones which was in the extra NodeMCU. I unlinked the Konnected and linked again but these devices keep appearing as off line.