Error triggering siren: Error doing job: Task exception was never retrieved


Has anyone else experienced this HA error? I'm running HA 0.84.6 in a docker container (not HASSIO).

It happens when trying to trigger the alarm siren.

Traceback (most recent call last):
  File "/usr/src/app/homeassistant/helpers/", line 277, in _handle_service_platform_call
    await getattr(entity, func)(**data)
  File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/app/homeassistant/components/switch/", line 73, in turn_on
    resp = self.client.put_device(
AttributeError: 'NoneType' object has no attribute 'put_device'

 My siren config looks like:


        - zone: out
          name: 'Outdoor siren'

 Konnected is receiving inputs from the sensors OK and HA is showing their states changing.

Did you have any luck with this?  I've been having the same issue.


Yes, Nate contacted me via my bug on GitHub. Basically the message means HA cannot discover the devices on the network. Discovery seems to be a bit hit and miss on these as I’ve other devices on the network that work fine e.g. Hue, Sonos etc. There is a guide with some tips to try and improve it here: but that didn’t help me. Finally I set the devices to have static IP’s in my router and had to use wireshark to monitor the traffic to those new IP’s to find the port no. for the device (there maybe easier way then this). I then edited the HA config to include the Host IP address and Port for each device and everything worked as expected.

Awesome!  Thanks for the update.  I'm learning multiple things through discovery as well and those have been fine.  The only other place I've had issues was with discovering multiple audio zones on an AV receiver and had to do roughly the same thing to fix that issue.  I'll go with static IPs and adjust my config.  

Not that it matters at this point but I'm seeing this issue on  0.86 on Hassbian.  Thanks again!

Just wanted to affirm that switching from discovery to host/port in my HA config did the trick.  Everything's working as expected now.

Hi Paul,

  I am getting same error for siren. My all other sensors are working fine.

  Error is coming both with and without SSL.

  I am not sure how api host /port will resolve - as other binary sensors are working fine.