Piezo Buzzer - no sound

I connected my Piezo Buzzer to my Alarm Panel Add-on board as shown on the "Wiring a Piezo Buzzer for Door Chime" installation instructions.  At first, I believe I was hearing a sound when I opened my door.  To test the range of the sound, I started walking around the house and pressing the beep button on the SmartApps panel to trigger the sound.  It was working like that for a while but then there was no sound when I opened any door.  At first I had it wired to the OUT and GND pins on the board.  Then I moved it to the OUT and GND on the terminal block and then onto terminal 4 and GND.  Nothing was helping.  Now, I can't even get the beep sound when I put it back on the OUT and GND pins on the board.

I'm still getting signals when I open or close any of the circuits but the buzzer is not working at all.  I did enable the Low Level Trigger via the SmartApps and verified the buzzer is still functioning.

Not sure what else I can share in this message but any help would be much appreciated.

I'm having the same problem.

I removed the configuration and reinstalled everything.  During the re-configuration, I put the buzzer on the main Alarm Panel instead of the Add-on.  I still don't get a beep when I open doors or windows but I can now enable the buzzer through smartthings and hear the beep.

Still trying to figure it all out.

You are using the smart lighting smart app right? I was struggling with this earlier until I found out that you had to set it to go off with open/close sensors in smart lighting!

I eventually figured out the need to configure it in smart lighting as well.  But, in the interim, the piezo suddenly was not visible to Smartthings as a switch.  I tried rebooting the konnected board, which did not help.  I have my piezo connected to the out, so I can have it wired upstairs near the old Vivint panel.  I was able to re-list it as a momentary switch on konnected, and could then be found again.  After that, I was able to see it again in Smartthings and configure it in smart lighting to activate with doors are opened.

Not optimal, in my mind, but working for the time being...

I'm not sure what you mean by the Smart Lighting app but I'm certainly willing to give it a try.  Is there some more details you could provide on your solution?

in the Automation tab of Smartthings:

  1. Tap SmartApps
  2. Add A SmartApp, then 
  3. Lights & Switches, then 
  4. Smart Lights, then 
  5. Which Device to Control, check the piezo, then
  6. How to trigger the action, check open/close, then check the sensor you want to beep, etc
Hope that helps.

 The piezo connection is a bit confusing (mainly on how it appears in SmartThings). As per https://docs.konnected.io/security-alarm-system/wiring/door-chime/ there are 3 ways. My question is how to appear it as a buzzer based on each way.

1. Connect to OUT and GND on Add-on card (use the female-female connector): I see a ALARM/OUT option to configure. Is this to be configured as a beep/blink switch in SmartLights?

2. Connect to OUT screw terminal and G (use the female-male connector): Same question as above.

3. Connect to a Zone: I did that as a zone on the add-on (for now). Configured it as a beep/blink switch.

So, confused on using the first 2 configurations.

Also, people are mentioning customizing beeps, # of beeps, low-level trigger etc. I do not see those options. Can someone tell me the steps to these options? Thx.

NOTE: I accidently chose ALARM/OUT on the Add-on to configure and gave a name. Now i cannot delete the name and still save the config. I cannot remove the ALARM/OUT entry so why this force check?

Not 100% sure I get your questions but let me try to answer them anyways. 

With the female to female connectors, you would connect directly to the pins on the left edge of the add on board (positive to the 5V pin, and the other to the ground (GND). 

For the male to female connectors, they're mainly for hooking up the buzzer to one of the zones and one of the grounds (the screws on the bottom). Again, the positive will go to a zone, and the other to the GND. 

For the customization, you're going to have to locate the piezo buzzer (or whatever you named it) under the tab my home. After you tap on it and enter the piezo screen, you can click on the settings cog on the top right to customize the beeps. 

The piezzo is polarity sensitive too, it didn't work for me at first because i had the wires swapped LOl

Hi All I have every thing running as should be except the piezzo buzzer I tried the instruction and now have it hooked into + zone 6 and - to one of the ground connectors on konnected  board. I received the board which only has 6 zone with no out. with this configuration I can not see the beep/blink switch. I do have an alarm installed and the beep/blink switch option  it is in the list when i go into alarm/out. any ideas or input would be great can i have the Piezzo with an alarm installed?

Thanks in advance


I was able to add my peizo and see it via the SmartLighting app, but the only option I have is for it to sound when a door is opened, and turn off after one minute.  No option for a chirp when the Konnected is not armed.  Does this sound consistent with you folks?  I'd like a chirp when someone comes in/out, even when the alarm is disarmed.  When it's armed, obviously "full on" is fine.  

 How loud is this peizo button.  I can barely hear it. 

I have the sane problem: the piezo sound is hardly audible.

My piezo buzzer is hardly audible as well.  It worked well when initially installed, however when I added the 12v to 5v charging adapter  for my hd7 panel, it dims the sound.  If I unplug the charger, it works as designed.

I have the buzzer working successfully.  Attaching screenshots from my SmartThings app to help anyone that has been unsuccessful.

I have 2 boards, and the buzzer is connected to my add-on board using the female-female cable connected to the instructed pins.

1. You will need to configure the buzzer using the "Alarm/out" on the board setup screen.  I set this as a "Momentary Switch"

2. Add a new routine

3. configure the routine to "turn on" the piezo when "something opens". I set this to beep on my less frequently used doors/windows so that it is not constantly beeping with the heavy traffic entry points.

4. On the "Things" listing screen, find your piezo and click the name (don't turn it on), and you will get the screen to configure the pulse/pause.

Hope this helps

I'm having the same issue. I've connected the piezo to the 6 zone alarm panel to zone 3, have it set in routine to beep 3 times when front door is triggered and still get nothing. 

I'm starting to think that the add - on board would have been the better option. Or have that as the standard board. In his video 5:45 sec he clearly has it demonstrated but never really shows how he programmed it to work. 

anyone else have the same issue on the regular alarm board? 

Followed Benjamins example however the only option I get is to set the delay.

I have tried all of the above. I have successfully added the new routine, but when I try to add the buzzer as a thing nothing shows up during search. As I went ahead and purchased an add on board solely for getting this to work I have two buzzers now and have tried connecting them to multiple spots, but they simply will not discover. Any ideas?

I have had it working for over a year.  Every time a zone opened with would toggle the buzzer.  One day it just stopped working.  I have tried everything and I can not get it to work again.  I might try resetting the boards and starting from scratch.  I wish someone would post a step by step of getting it working.