Garage door opener wired sensor

I got my garage door opener setup in Home Assistant and calibrated but was wondering how do you set it up to use a wired sensor instead of the optical sensor I’m not seeing how to tell it which to use?

Also I found out the “switch” device that gets created in Home Assistant is for the strobe output.


Update: I asked support how to change to the wired sensor and Andy sent me this URL: ESPHome: Customization on the Garage Door Opener

I was able to figure out where to go to use the steps in the URL eventually:

  • In Home Assistant Settings->Add-ons then click the Add-on store to add ESPHome then install
  • After it is installed start it then click Open web UI
  • In the web UI click adopt on the garage door
  • During adoption you will need to provide your WIFI info for the config to use when customizing
  • After that I could edit the garage door there and make the changes then save and install the updated config (I added the binary_sensor option to the end to show the wired sensor as a separate device).
  • Once the config finished installing (about 5.5 minutes) I saw success then saw the logs looking for the door so I opened it, once it saw it I clicked stop since it was just repeating the logs at that point showing how far the door was from the sensor.
  • When I went back to the garage door device the wired sensor showed up as a device like I wanted.

At this point I haven’t switched to using the wired sensor and just made it visible in Home Assistant so I can see if there is much difference in reliability between them and if there is decide which to use later.

Glad you figured it out! Let us know if you still have any questions about this.

1 Like

If a home has both the Konnected garage-door-opener and the alarm-panel-pro, can the same magnetic sensor be wired to both devices or would doing so require two magnetic sensors?

I haven’t tried to connect to both but I can’t see why you couldn’t wire it to both as each is just looking for a change of continuity from the sensor.

No, a single sensor can’t be wired to two initiating devices.

But you shouldn’t need to do that anyway because if you have the sensor in your smart home platform once, you don’t need it twice.

UPDATE: Since release 2023.11.2 of our ESPHome firmware, the wired input is exposed by default. So you don’t have to do this extra work to customize the firmware anymore if you want direct access to the wired input!

1 Like

Hey @nate, I just got my two units installed and onboarded in Home Assistant. As mentioned, the wired sensor status is now exposed by default and it updates properly.

Unfortunately my ceiling is too high (and I have bike hoists in the way) so I can’t really use the optical sensor at all.

Is there an easy way to choose which sensor option is used to convey the cover state? Right now it seems like cover state is hard set to derive by optical sensor only, and wired state is just a secondary sensor.

If this isn’t possible or isn’t planned, can anyone weigh in on how to do this in an alternative manner?

Yes, the cover entity in Home Assistant is what controls the actual garage door states and control. We provide three different garage door cover packages for different configurations. You just have to customize your ESPHome config to use the cover entity that incorporates the wired sensor.

See the article ESPHome: Customization on the Garage Door Opener under the heading Using a Wired Sensor Instead of Optical Range Sensor.

I’m trying to follow the documentation on this process but I’m having an awful time of it. It seems like anytime I try to rebuild the install for the devices, it either fails to install or it won’t onboard back into HASS afterward without re-installing the original default.

I don’t consider myself an expert in this field, but I do feel like I shouldn’t be struggling this much to make it work.

@panamasaylor I can only help if you can be more specific about what errors or failures you’re getting.

Sorry about that. I was tired and had just given up. I’ll be digging back into it a bit more in the next couple of days.


  • The devices were already connected and onboarded in Home Assistant.
  • I then took the custom configurations (modified with the API key for each unit) and edited the devices in ESPHome
  • The next step seems to be installing the revised configuration and this is when i run into problems.

Uploading: [============================================================] 100% Done…

INFO Waiting for result…
INFO OTA successful
INFO Successfully uploaded program.
INFO Starting log output from garage-door-6f4a9f.local using esphome API
WARNING Can’t connect to ESPHome API for garage-door-6f4a9f: Error resolving IP address: [Errno -5] No address associated with hostname (APIConnectionError)
INFO Trying to connect to garage-door-6f4a9f in the background

  • So from here I can see that the update seems to compile and then upload successfully to the device, but then it doesn’t come back.
  • The current ESPHome device goes into the offline state, and a “new” device is once again discovered by ESPhome with the option to adopt it again
  • Adopting the “new” device again will fail unless the original device is deleted.
  • If I delete the original device and adopt the new device, it will succeed, but it overwrites the device with the default configuration once more.


  • I’ve only tested this with wireless connections because the units are mounted and I don’t have a good way to repeatedly get access to them again.
  • As of my testing this morning, the same behavior is happening with the device getting discovered as an adoptable device in ESPHome again, but the configuration of the wired sensor as default does seem to be taking and working properly.

@panamasaylor Please post or send me your YAML configuration. It sounds like you are inadvertently changing the hostname of the device so when it comes back up after the update it has a different name. That’s why it’s not re-connecting and shows up as newly adoptable again.

Hey @nate, I think I’ve figured it out. There was a bit of hostname change occurring from time to time, but not always.

When i first started trying to update the parameters, I modified the configurations based on what was on the tutorial page. But this ALWAYS resulted in a logger error occurring. So I had pulled the configuration from github and was modifying it instead.

What I had not done was copy over the ESPHome and Substitutions fields. I had falsely figured these would get updated in the process, but realize now that was a mistake on my part.

With these fields added back into the update configuration, the install is completing successfully with no logger errors and it’s retaining the hostname information as well.

1 Like

Glad you figured it out. Yes, there’s a learning curve to ESPHome customization. I’m trying to make it more easy/accessible for regular people to customize, so rest assured this process should get simpler over time.